“generic” types: what’s in a name?

I’ve been stumbling over Java’s generic types for a while now…  I think I finally understand what my problem is:

They should be called specific types, or parametrised collections!

Continue reading

Advertisements